Интерфейс TwinRewrite

TwinRewrite обладает современным и интуитивно понятным интерфейсом. Большинство элементов управления должно быть знакомо всем, кто хоть раз пользовался текстовыми редакторами, публиковал записи в блогах.

Главное окно TwinRewrite, помимо меню, панели инструментов и строки состояния, характерных для многих программ, поделено на 3 части (слева направо):

  • исходный текст;
  • область с текстом документа (в режиме «Редактирование») / предварительный просмотр публикации (в режиме «Предпросмотр»);
  • боковая панель (статистика, цена, ключевые слова).

      

Меню программы

Меню «Файл»

«Новый» — очистка текстовых полей и создание нового документа.

«Открыть…» — открыть файл с исходным текстом, либо с текстом документа, в зависимости от того, в каком текстовом поле находится курсор.

«Сохранить» — сохранить произведенные изменения в файле документа, если он уже был сохранен ранее.

«Сохранить как…» — сохранить произведенные изменения в документе в новом файле, под другим именем.

«Выход» — выйти из программы. Если документ не был сохранен, будет выведен запрос на сохранение.

Меню «Правка»

Команды применяются там, куда установлен курсор — в поле исходного текста или в поле документа.

«Отменить» / «Повторить» — отменяет совершенное с документом действие, либо, соответственно, повторяет его. С исходным текстом не работает.

«Вырезать» — вырезает выделенный текст и помещает его в буфер обмена.

«Копировать» — помещает выделенный текст в буфер обмена.

«Вставить» — извлечь текст из буфера обмена в то место, где установлен курсор.

«Удалить» — удалить выделенный текст.

«Удалить всё» — очистить всё содержимое текстового поля.

«Выделить всё» — установить выделение всего текста в текстовом поле.

«Найти и заменить…» — открыть окно для поиска и замены текста.

Меню «Вид»

«Редактирование» - переход в режим правки текста документа.

«Предпросмотр» - переход к предварительному просмотру документа во встроенном окне браузера.

«Панель инструментов» — показывает и прячет панель инструментов.

«Размер значков» — выбор размера значков панели инструментов. Предлагаются «большие» (32х32), «средние» (24х24) и «маленькие» (16х16) значки.

«Стиль значков» — выбор стиля значков панели инструментов. На выбор — «серые» и «цветные» значки.

«Исходный текст» — показывает и прячет область с исходным текстом.

«Боковая панель» — показывает и прячет боковую панель целиком.

«Статистика» — показывает и прячет блок статистики на боковой панели. Можно показывать и скрывать отдельные составляющие статистики - на выбор опции «С пробелами», «Без пробелов», «Слов», «Предложений», «Абзацев».

«Цена» — показывает и прячет блок цены на боковой панели.

«Ключевые слова» — показывает и прячет блок ключевых слов на боковой панели.

«Строка состояния» — показывает и прячет информационную строку состояния.

«Масштаб текста» — отвечает за выбор размера шрифта документа. На форматирование текста влияния не оказывает. Доступны команды «Уменьшить» и «Увеличить».

Меню «Вставка»

«Ссылка…» — вставить ссылку в текст документа. Используется весь спектр html-тегов для формирования ссылки.

«Изображение…» — вставить изображение в документ. Вставляются только изображения по ссылке.

«Видео…» — вставить видео в документ. Поддерживаются вставка видео, доступных по прямой ссылке, а также на YouTube.

«Таблица…» — вставить таблицу в документ. Вставляется только каркас таблицы, состоящий из заданного количества столбцов и строк.

«E-mail…» — вставить адрес электронной почты в текст документа. Используется весь спектр атрибутов протокола mailto для формирования ссылки.

«Аудио…» — вставить аудио в документ. Поддерживаются вставка аудио, доступных по прямой ссылке.

«Специальные символы…» — вставить спецсимвол из набора. Символы вставляются в виде html-кодов. Для отображения данных символов требуется использовать шрифт, содержащий их.

«Горизонтальная линия» — вставить разделительную линию при помощи тега <hr>.

Меню «Формат»

«Абзац» — оформить выделенный текст тегами <p></p>.

«Заголовок 1» — выделить заголовок 1-го уровня тегами <h1></h1>.

«Заголовок 2» — выделить заголовок 2-го уровня тегами <h2></h2>.

«Заголовок 3» — выделить заголовок 3-го уровня тегами <h3></h3>.

«Заголовок 4»— выделить заголовок 4-го уровня тегами <h4></h4>.

«Заголовок 5» — выделить заголовок 5-го уровня тегами <h5></h5>.

«Заголовок 6» — выделить заголовок 6-го уровня тегами <h6></h6>.

«Цитата» — сделать выделенный текст цитатой с помощью тегов <blockquote></blockquote>.

«Код» — сделать выделенный текст кодом с помощью тегов <code></code>.

«Жирный» — оформить выделенный текст тегами <strong></strong>.

«Курсив» — оформить выделенный текст тегами <em></em>.

«Подчеркнутый» — оформить выделенный текст тегами <ins></ins>.

«Зачеркнутый» — оформить выделенный текст тегами <del></del>.

«Маркированный список» — оформить выделенный текст в виде списка с помощью тегов <ul></ul>.

«Нумерованный список» — оформить выделенный текст в виде списка с помощью тегов <ol></ol>.

Меню «Сервис»

«Настройки…» — открывает окно с параметрами программы.

«Типографировать…» — выполняет типографирование текста, копируя соответствующую команду с панели инструментов. Подробнее в разделе «Подготовка публикации».

Меню «Справка»

«Справка и поддержка…» — открывает данную документацию в формате PDF, либо html-версию в браузере.

«Пожертвовать…» — открывает в браузере страницу «Поддержать проект» официального сайта.

«Сообщить об ошибке…» — открывает в браузере страницу с формой для сообщения о найденной ошибке.

«Отзывы и предложения…» — открывает страницу, где можно оставить предложение или пожелание.

«О программе…» — показывает окно с информацией о программе, ее авторе и лицензии.

«Проверить обновление…» — запускает проверку наличия новой версии программы.

Панель инструментов

Ниже перечислены все кнопки, содержащиеся на панели инструментов (слева направо).

Операции по вставке и форматированию работают только с текстом документа, к исходному тексту отношения не имеют.

С исходным текстом могут использоваться команды из меню «Файл» и «Правка».

Назначение кнопок соответствует назначению аналогичных команд меню.

  • «Новый»;
  • «Открыть»;
  • «Сохранить»;
  • «Вырезать»;
  • «Копировать»;
  • «Вставить»;
  • «Отменить»;
  • «Повторить»;
  • «Найти и заменить…»;
  • «Вставить ссылку…»;
  • «Вставить изображение…»;
  • «Вставить видео…»;
  • «Вставить таблицу…»;
  • «Вставить e-mail…»;
  • «Вставить аудио…»;
  • «Вставить спецсимвол…»;
  • «Стиль» (выпадающий список команд соответствует меню «Формат»);
  • «Жирный»;
  • «Курсив»;
  • «Зачеркнутый»;
  • «Маркированный список»;
  • «Нумерованный список»;
  • «Типографировать…»;
  • «Настройки…».

       

Боковая панель

Содержит блоки статистики символов, цены текста и ключевых слов. Любой блок можно свободно скрыть / показать, чтобы не нагромождать интерфейс теми элементами, которые вам не нужны. Сама боковая панель также может быть скрыта через команду меню «Вид» – «Боковая панель».

Исходный текст

Область для исходного текста расположена в левой части окна программы. В неё можно вставлять / вводить / перетаскивать любые текстовые фрагменты, нужные для написания собственного текста.

Область документа

Основная рабочая область программы, работающая в двух режимах - «Редактирование» и «Предпросмотр».

В режиме редактирования доступны все возможности по форматированию текста и вставке нужных объектов (изображений, ссылок, видео и т.д.). Все HTML-теги и атрибуты подсвечиваются, тем самым значительно упрощая редактирование документа.

В режиме предпросмотра открывается встроенное окно браузера, отображающее созданный вами документ в таком виде, в каком он может быть представлен при публикации на сайте.

Документ показывается «как есть», без использования CSS.

Строка состояния

Снизу располагается строка состояния, в которой могут быть выведены:

  • адрес открытого файла;
  • дата создания;
  • дата последнего изменения.

     

Это справедливо как для исходного текста, так и для итогового документа.

Работая с этим сайтом, вы даете свое согласие на использование файлов cookie. Это необходимо для нормального функционирования сайта, показа целевой рекламы и анализа трафика. Статистика использования сайта отправляется в Google и Яндекс.

Справка и поддержка

TwinRewrite обладает подробной справочной системой, доступной на данном сайте и содержащей исчерпывающую информацию обо всех функциях.

Кроме того, вы всегда можете задать вопрос или высказать свои пожелания через форму «Отзывов и предложений».

Подпишитесь также на ежемесячную рассылку блога TwinRewrite. Обзор нововведений, различные лайфхаки.

В помощь рерайтеру

Рерайт — это оригинальный текст, получающийся путем передачи своими словами исходного текста. Рерайты используются для наполнения сайтов.

TwinRewrite упрощает написание рерайта, подсчитывая статистику, стоимость текста и процентное содержание ключевых слов.

Также помогает подготовить рерайт к публикации, добавив ссылки и изображения, отформатировав текст, выделив заголовки.

Вперед в будущее

Постоянно развиваясь, TwinRewrite остается предельно простым инструментом для написания различных текстов.

И если сейчас TwinRewrite не может решить всех проблем, с которыми сталкиваются рерайтеры, то стремится к этому. Новые функции не за горами.

Цель приложения — стать основным инструментом на всех этапах создания текста — от идеи до результата.